[Coco] Toolshed DSAVE issues.

William Carlin whcarlinjr at gmail.com
Mon Sep 21 23:27:58 EDT 2020


This is what works for me.  I have a folder where I place my virtual disk
and in a subfolder within that folder, my source files.

In this example I am copying all of the Climax C Compiler files onto a
8.5MB DriveWire virtual disk.  My virtual disk is ClimaxCC.os9 and my
source files are all located in the ClimaxCC_Files folder.  Below is a
representation of my files:

wcarlin at Ubuntu-VirtualBox:/usr/local/src/nitros9/dsks/ClimaxCC$ ls -R
ClimaxCC_Files  ClimaxCC.os9

ANSIFront           C-Language             cprep19.doc.txt  r63.doc.txt
ansifront-note.txt  Climax_CMDS_40T2S.dsk  LHA              RMA
cc252               ClimaxFIles.zip        MAKE
cc.doc.txt          cprep19b               Make.help.txt

 ansifront          ansifront.note

cc252.lzh  cc.doc


cp1.c  cp3.c  cp.c  c_prep     cprep19.doc  makefile
cp2.c  cp4.c  cp.h  c_prep19b  findstr.c    solve.a




Here is the command I use to dsave all the files from the ClimaxCC_Files
folder to the ClimaxCC.os9 virtual disk and the generated dsave script:

wcarlin at Ubuntu-VirtualBox:/usr/local/src/nitros9/dsks/ClimaxCC$ os9 dsave
./ClimaxCC_Files/ ./ClimaxCC.os9, -e
os9 makdir './ClimaxCC.os9,ANSIFront'
os9 copy './ClimaxCC_Files/ANSIFront/ansifront'
'./ClimaxCC.os9,ANSIFront/ansifront'  -b=32768
os9 copy './ClimaxCC_Files/ANSIFront/ansifront.note'
'./ClimaxCC.os9,ANSIFront/ansifront.note'  -b=32768
os9 copy './ClimaxCC_Files/ANSIFront/ansifront012.lzh'
'./ClimaxCC.os9,ANSIFront/ansifront012.lzh'  -b=32768
os9 copy './ClimaxCC_Files/ansifront-note.txt'
'./ClimaxCC.os9,ansifront-note.txt'  -b=32768
os9 makdir './ClimaxCC.os9,C-Language'
os9 copy './ClimaxCC_Files/C-Language/clang.zip'
'./ClimaxCC.os9,C-Language/clang.zip'  -b=32768
os9 copy './ClimaxCC_Files/cc.doc.txt' './ClimaxCC.os9,cc.doc.txt'  -b=32768
os9 makdir './ClimaxCC.os9,cc252'
os9 copy './ClimaxCC_Files/cc252/cc.doc' './ClimaxCC.os9,cc252/cc.doc'
os9 copy './ClimaxCC_Files/cc252/cc252.lzh'
'./ClimaxCC.os9,cc252/cc252.lzh'  -b=32768
os9 copy './ClimaxCC_Files/ClimaxFIles.zip'
'./ClimaxCC.os9,ClimaxFIles.zip'  -b=32768
os9 copy './ClimaxCC_Files/Climax_CMDS_40T2S.dsk'
'./ClimaxCC.os9,Climax_CMDS_40T2S.dsk'  -b=32768
os9 copy './ClimaxCC_Files/cprep19.doc.txt'
'./ClimaxCC.os9,cprep19.doc.txt'  -b=32768
os9 makdir './ClimaxCC.os9,cprep19b'
os9 copy './ClimaxCC_Files/cprep19b/cp.c' './ClimaxCC.os9,cprep19b/cp.c'
os9 copy './ClimaxCC_Files/cprep19b/cp.h' './ClimaxCC.os9,cprep19b/cp.h'
os9 copy './ClimaxCC_Files/cprep19b/cp1.c' './ClimaxCC.os9,cprep19b/cp1.c'
os9 copy './ClimaxCC_Files/cprep19b/cp2.c' './ClimaxCC.os9,cprep19b/cp2.c'
os9 copy './ClimaxCC_Files/cprep19b/cp3.c' './ClimaxCC.os9,cprep19b/cp3.c'
os9 copy './ClimaxCC_Files/cprep19b/cp4.c' './ClimaxCC.os9,cprep19b/cp4.c'
os9 copy './ClimaxCC_Files/cprep19b/cprep19.doc'
'./ClimaxCC.os9,cprep19b/cprep19.doc'  -b=32768
os9 copy './ClimaxCC_Files/cprep19b/c_prep'
'./ClimaxCC.os9,cprep19b/c_prep'  -b=32768
os9 copy './ClimaxCC_Files/cprep19b/c_prep19b'
'./ClimaxCC.os9,cprep19b/c_prep19b'  -b=32768
os9 copy './ClimaxCC_Files/cprep19b/findstr.c'
'./ClimaxCC.os9,cprep19b/findstr.c'  -b=32768
os9 copy './ClimaxCC_Files/cprep19b/makefile'
'./ClimaxCC.os9,cprep19b/makefile'  -b=32768
os9 copy './ClimaxCC_Files/cprep19b/solve.a'
'./ClimaxCC.os9,cprep19b/solve.a'  -b=32768
os9 makdir './ClimaxCC.os9,LHA'
os9 copy './ClimaxCC_Files/LHA/lha_2_11c.lzh'
'./ClimaxCC.os9,LHA/lha_2_11c.lzh'  -b=32768
os9 makdir './ClimaxCC.os9,MAKE'
os9 copy './ClimaxCC_Files/MAKE/Make_TK.lzh'
'./ClimaxCC.os9,MAKE/Make_TK.lzh'  -b=32768
os9 copy './ClimaxCC_Files/Make.help.txt' './ClimaxCC.os9,Make.help.txt'
os9 copy './ClimaxCC_Files/r63.doc.txt' './ClimaxCC.os9,r63.doc.txt'
os9 makdir './ClimaxCC.os9,RMA'
os9 copy './ClimaxCC_Files/RMA/rma_1_3_patch.lzh'
'./ClimaxCC.os9,RMA/rma_1_3_patch.lzh'  -b=32768

Here is a recursive directory of the target virtual disk after the dsave
was complete:

wcarlin at Ubuntu-VirtualBox:/usr/local/src/nitros9/dsks/ClimaxCC$ os9 dir -r

                           Directory of ./ClimaxCC.os9,
ANSIFront       ansifront-note.txt C-Language      cc.doc.txt      cc252
ClimaxFIles.zip Climax_CMDS_40T2S.dsk cprep19.doc.txt cprep19b        LHA
MAKE            Make.help.txt   r63.doc.txt     RMA

                           Directory of ./ClimaxCC.os9,/ANSIFront
ansifront       ansifront.note  ansifront012.lzh

                           Directory of ./ClimaxCC.os9,/C-Language

                           Directory of ./ClimaxCC.os9,/cc252
cc.doc          cc252.lzh

                           Directory of ./ClimaxCC.os9,/cprep19b
cp.c            cp.h            cp1.c           cp2.c           cp3.c
cp4.c           cprep19.doc     c_prep          c_prep19b       findstr.c
makefile        solve.a

                           Directory of ./ClimaxCC.os9,/LHA

                           Directory of ./ClimaxCC.os9,/MAKE

                           Directory of ./ClimaxCC.os9,/RMA

Hope this helps clear up any confusion.  It took a good bit of trial and
error to get the ToolShed syntax correct when I first started using it.
Some real world examples should really be added to the documentation.  My
largest hurdles were using the comma correctly, whether to use or not use a
preceding forward slash when referring to the root folder on the
virtual disk, and not using wildcards; just letting dsave do its thing.

William Carlin

On Mon, Sep 21, 2020 at 9:19 PM <coco at jechar.ca> wrote:

>   No also tryed
> os9 dsave -e . ../newvirtualos9disk.dsk,
> fails as well.
> tried without the -e and redirected the script to out
> os9 makdir "../Quilt-Release-1.0.dsk,/.."
> os9 copy './../BOOT-SeptDEV.dsk'
> '../Quilt-Release-1.0.dsk,/../BOOT-SeptDEV.dsk'  -b=32768
> os9 makdir "../Quilt-Release-1.0.dsk,/../.."
> os9 makdir "../Quilt-Release-1.0.dsk,/../../TESTING"
> os9 copy './../../TESTING/BOOT-SeptDEV.dsk'
> '../Quilt-Release-1.0.dsk,/../../TESTING/BOOT-SeptDEV.dsk'  -b=32768
> os9 makdir "../Quilt-Release-1.0.dsk,/../../TESTING/.."
> os9 makdir "../Quilt-Release-1.0.dsk,/../../TESTING/../TESTING"
> .....
> and after 120+ more lines of this nonsense
> os9 makdir
> *** buffer overflow detected ***: os9 terminated
> Aborted (core dumped)
> Also tried using the absolute path same problem.
> I am going to write some basic09 code to take the output of the linux ls
> -LR1 command and create
> a script for toolshed to import linux files into a os9 disk.
> So I can run ls -LR1 > out in linux copy out to my os9 system and run a
> basic09 program to create the
> script that linux can run to import all those files.
> Convoluted yes but better than having to manually copy one file at a
> time from linux to os9.
> What would really be amazing, but way beyond what I could figure out how
> to do would be
> to be able to make it possible for linux to mount a .dsk file and then
> treat it just like a
> any other mounted partition.
> Charlie.
> On 2020-09-21 13:55, tim lindner wrote:
> > On Mon, Sep 21, 2020 at 8:34 AM <coco at jechar.ca> wrote:
> >>   os9 dsave -e . newvirtualos9disk.dsk,
> >>
> >>   does not copy it back to the new disk just generates errors :(
> >
> > I just tried some simple tests and all worked fine.
> >
> > Could it be because of the recursive nature of having the destination
> > disk image in the source folder?
> >
> >
> > --
> > --
> > tim lindner
> >
> > "Proper User Policy apparently means Simon Says."
> --
> Coco mailing list
> Coco at maltedmedia.com
> https://pairlist5.pair.net/mailman/listinfo/coco

More information about the Coco mailing list