[Coco] Toolshed DSAVE issues.

coco at jechar.ca coco at jechar.ca
Mon Sep 21 21:18:55 EDT 2020

  No also tryed

os9 dsave -e . ../newvirtualos9disk.dsk,

fails as well.

tried without the -e and redirected the script to out

os9 makdir "../Quilt-Release-1.0.dsk,/.."
os9 copy './../BOOT-SeptDEV.dsk' 
'../Quilt-Release-1.0.dsk,/../BOOT-SeptDEV.dsk'  -b=32768
os9 makdir "../Quilt-Release-1.0.dsk,/../.."
os9 makdir "../Quilt-Release-1.0.dsk,/../../TESTING"
os9 copy './../../TESTING/BOOT-SeptDEV.dsk' 
'../Quilt-Release-1.0.dsk,/../../TESTING/BOOT-SeptDEV.dsk'  -b=32768
os9 makdir "../Quilt-Release-1.0.dsk,/../../TESTING/.."
os9 makdir "../Quilt-Release-1.0.dsk,/../../TESTING/../TESTING"

and after 120+ more lines of this nonsense

os9 makdir 

*** buffer overflow detected ***: os9 terminated
Aborted (core dumped)

Also tried using the absolute path same problem.

I am going to write some basic09 code to take the output of the linux ls 
-LR1 command and create
a script for toolshed to import linux files into a os9 disk.
So I can run ls -LR1 > out in linux copy out to my os9 system and run a 
basic09 program to create the
script that linux can run to import all those files.

Convoluted yes but better than having to manually copy one file at a 
time from linux to os9.

What would really be amazing, but way beyond what I could figure out how 
to do would be
to be able to make it possible for linux to mount a .dsk file and then 
treat it just like a
any other mounted partition.


On 2020-09-21 13:55, tim lindner wrote:
> On Mon, Sep 21, 2020 at 8:34 AM <coco at jechar.ca> wrote:
>>   os9 dsave -e . newvirtualos9disk.dsk,
>>   does not copy it back to the new disk just generates errors :(
> I just tried some simple tests and all worked fine.
> Could it be because of the recursive nature of having the destination
> disk image in the source folder?
> --
> --
> tim lindner
> "Proper User Policy apparently means Simon Says."

More information about the Coco mailing list