[Coco] NitrOS9 wildcarding

L. Curtis Boyle curtisboyle at sasktel.net
Sun Dec 11 01:27:34 EST 2016

Shellplus’s wildcards had the BIG problem of having a much smaller buffer to work with (see Gene Heskett’s comments). You only had 1K or so (been awhile since I worked on it, so I don’t remember the exact size) to buffer all matching filenames in a directory. On a floppy; not as much of a big deal (well, on 720K+ disks, it definitely could be), but on a hard drive it was nigh useless, giving “expanded line too long” or something like that with any fairly general searches. So it never did work quite right in Shellplus 2.1 (or 2.2, or 2.2a - they all had the same restriction). Alan’s DIR command (I just fixed a couple of bugs in it) did everything internally to itself, and only had to do matches one at a time to put on screen; so it worked fine no matter how many file entries matched the wildcard. Shellplus had to fit all of them, concatenated, in it’s internal line buffer (so as to pass them on to the calling program).
That’s why a fair number of 3rd party wildcarding utilities did NOT use Shellplus’s wildcard system (SDIR, Alan’s DIR, the MS* commands from Sardis/DP Johnson, etc.); it was too limited, especially on large directories (and I don’t think Shellplus supported recursive directory searching at all).

On the other hand, Shellplus *did* support the Unix-style [a-z] range wildcarding, though, which most independent utilities did not. I ended up using a hybrid of both, depending on what I was doing at the time.

L. Curtis Boyle
curtisboyle at sasktel.net

> On Dec 10, 2016, at 11:51 PM, Stephen H. Fischer <SFischer1 at Mindspring.com> wrote:
> It was in ShellPlus.
> ftp://www.rtsi.com/OS9/OS9_6X09/APPS/ShellPlus_2_1.lzh
> Later mods may have broken ShellPlus in ways that could not be fixed.
> ----- Original Message ----- 
> From: "Dave Philipsen" <dave at davebiz.com>
> To: "CoCoList for Color Computer Enthusiasts" <coco at maltedmedia.com>
> Sent: Saturday, December 10, 2016 9:35 PM
> Subject: Re: [Coco] NitrOS9
>> I'm just guessing here but probably the wildcard expansion was not a 
>> part of the 'dir' command.  It was probably built into shell and 
>> therefore would affect anything you type on the command line.
>> Dave
>> On 12/10/2016 11:21 PM, Barry Nelson wrote:
>>> On Saturday 10 December 2016 17:01:42 L. Curtis Boyle wrote:
>>>> Robert is correct in that some things have changed - the ‘-‘ sign on a
>>>> lot of commands is one. TMODE and XMODE are radically different than
>>>> the original OS-9 (and if you pull down some older OS-9 programs that
>>>> fork out to these commands, they will not work properly without
>>>> patching). So, you are correct in that we need some proper
>>>> documentation (even just documenting differences/additions would be
>>>> helpful). Another issue is that some commands in later NitrOS-9 (DIR
>>>> is a prime example for me) have actually gone backwards from original
>>>> NitrOS-9. As of version 2.01 of NitrOS-9, DIR had wildcard support
>>>> (both * and ?), and extra options for recursive directory searches,
>>>> etc. Then, for some unknown (to me) reason, that new “standard
>>>> version” disappeared, and it went back to stock OS-9 in functionality,
>>>> but with the ‘-‘ now required. And there are other examples like this
>>>> as well.
>>> I definitely miss the wildcard expansion. Why was it removed? Especially from a command like dir where no changes are made to the filesystem by the command.
>> -- 
>> Coco mailing list
>> Coco at maltedmedia.com
>> https://pairlist5.pair.net/mailman/listinfo/coco
> -- 
> Coco mailing list
> Coco at maltedmedia.com
> https://pairlist5.pair.net/mailman/listinfo/coco

More information about the Coco mailing list