[Coco] MESSUI 0.154 with Becker port

Bill Pierce ooogalapasooo at aol.com
Sun Sep 21 22:05:51 EDT 2014

I'm having quite a few problems with Mess w/becker (gui version).
First, mixing emudsk with dw drivers in nitros9 seems to screw everything up. I run this type of setup daily in VCC.
Floppy drives do not work while in HDBDOS (DRIVEOFF)
Coco 2b shows multiple errors before finally running. Seems like there were others too.
Several emulations say the roms are wrong.
the coco3dw1 crashed with me on several occassions, especially while trying to compile C programs in nitros9, I got all kinds of errors on sources that normally compile in Vcc and on my Coco3.
Several other problems I can't think of at the moment.
I eventually went back to Vcc where I knew I could work on my projects safely

Something is definately not right with the gui build. I had better luck with Richard's original patch, but still had some problems there too.
For now, I'll stick with Vcc.. it's still the most stable with dw4.

Bill Pierce
"Today is a good day... I woke up" - Ritchie Havens

My Music from the Tandy/Radio Shack Color Computer 2 & 3
Co-Webmaster of The TRS-80 Color Computer Archive
Co-Contributor, Co-Editor for CocoPedia
E-Mail: ooogalapasooo at aol.com

-----Original Message-----
From: Guillaume Major <gmajor at videotron.ca>
To: coco <coco at maltedmedia.com>
Sent: Sun, Sep 21, 2014 7:08 pm
Subject: Re: [Coco] MESSUI 0.154 with Becker port

Hi Robert,

I don't know if it's a bug or by design, but now when you mount a cartridge 
in MESS, the floppy drives are disabled and won't come back until you 
reenable them. To reenable the floppy drives, press Scroll Lock to enter the 
partial keyboard emultation mode, then TAB to show up the configuration 
menu. Select Slot Devices, change the "ext" value for "fdcv11" and choose 

I successfully booted into Nitros-9 on VCC configured with a 6309 CPU, using 
the Coco 3 6309 Becker port version of Nitros-9. I have no idea what might 
be wrong on your side.

Also, since the introduction of the "Slot Devices" functionality, all banked 
cartridges like Robocop, Predator and Mind Roll don't work anymore. I tried 
selecting the "banked_16K" option in the Slot Devices menu to no avail. Same 
problem with the Orchestra 90-CC. Support for this cart seems to be 
currently broken. When I select "orch90" in the Slot Devices menu and mount 
the Orchestra 90-CC cartridge, MESS stops responding and crashes. If I leave 
the Slot Devices setting to "pak", there is no sound output.

Is anybody else experiencing the same problems with MESS?


"Robert Gault" <robert.gault at att.net> a écrit dans le 
message de news:5410585E.3080405 at att.net...
> Guillaume Major wrote:
>> Hi Robert,
>> I uploaded Richard's original patch and my patch on the Color Computer 
>> Archive.
>> You can get them at:
>> http://www.colorcomputerarchive.com/coco/Emulators/MESS/Source/Becker%20port%20patch/
> Guillaume,
> The patch works for me at rev 32053 but can't compile the ui version until 
> that private patch gets updated on the release of .155.
> There are some strange things about the patch for MESS. Do you see this on 
> your system? With the 154UI version you posted, MESS does not show any 
> floppy drives. Regardless of what is done with the MESS menus, you can't 
> get floppy drives to show or mount images.
> With my compilation of the MESS command line more recent version, I do 
> have floppies. Also I can run coco2b, coco3, and coco3h with Drivewire. I 
> have not tried other combinations.
> We need to determine if this is a MESS bug or a Becker Patch bug.
> There is a major bug with all Drivewire emulator/coco combinations on my 
> system. Do you see this?
> Start Drivewire4 (current version) with a suitable NitrOS-9 disk mounted 
> in DWdrive0. Start any emulator with the Becker version, MESS, VCC, or 
> real Coco3 with 6309. Boot NitrOS-9, and at the first attempt at DW access 
> after the welcome message is shown, the emulator/coco will crash and 
> reboot the ROM. Any subsequent attempt to boot NitrOS-9 works normally.
> You can access Drivewire4 normally (even just after starting it) if you 
> don't use NitrOS-9.
> I think but am not sure that the crash has something to do with starting 
> the NitrOS-9 clock as when a DW4 clock module is used, the date is not 
> correct until about 1 minute after NitrOS-9 is running.
> Robert
> -- 
> Coco mailing list
> Coco at maltedmedia.com
> https://pairlist5.pair.net/mailman/listinfo/coco

Coco mailing list
Coco at maltedmedia.com


More information about the Coco mailing list