[Coco] EmuDisk floppy utility issue

Bill Pierce ooogalapasooo at aol.com
Wed Jan 1 23:09:19 EST 2020

Actually, there's quite a few issues with that software. I wouldn't move anything around in OS-9 with it, without a backup.
He had a good plan and good concept, he just never worked the kinks out of it.
-----Original Message-----
From: Wayne Campbell <asa.rand at gmail.com>
To: CoCoList for Color Computer Enthusiasts <coco at maltedmedia.com>
Sent: Wed, Jan 1, 2020 8:06 pm
Subject: [Coco] EmuDisk floppy utility issue

It's been a few years since this utility was written. I don't know if Walt
Zydhek is still around, but if he is I have found an issue with EmuDisk
that needs to be addressed. I used the utility to copy a text file from a
floppy image to a windows folder. When I tried to open it with TextPad (the
editor of choice for me), TextPad reported "Unspecified Error", and when I
clicked the OK button I got another dialog stating, "Unexpected and
unrecoverable error. Would you like to save a diagnostic file?" TextPad
then quit after clicking either of the buttons (Yes or No). I opened the
file with Notepad and it opened fine.

If I save the file out with wimgtool, the file opens without error in
TextPad. I don't understand what is causing the issue, but it appears to be
related to how EmuDisk is saving the file. I also compared the two copies
(one from wimgtool and one from EmuDisk) in the file comparison utility
WinMerge and it showed both files being identical. This just adds to my
confusion, as one opens in TextPad and Notepad and the other only opens in

I would appreciate any help in figuring out what is happening here, but I
haven't heard from Walt in a long time. In the meantime I am just using
wimgtool to copy files from floppy images to my windows folders.


The Structure of I-Code

Coco mailing list
Coco at maltedmedia.com

More information about the Coco mailing list