[Coco] CoCo 1 troubles

Salvador Garcia salvadorgarciav at yahoo.com
Mon Dec 21 23:23:27 EST 2020

 Thanks Art!
I am one step closer. I reseated all the socketed chips, I also disconnected and reconnected the KB connector. I cleaned the edge connectors on the disk controller cartridge.
This seems to have mitigated the problem with the keys. I still lose a keystroke, but not as frequent. Thanks to Rietveld, I will soon have a second KB to test.
Now, when I insert a diskette and try to format it, I get an IO error. Sigh. Reading the user's guide for the disk system, I am now at the third troubleshooting tip: Contact Radio Shack repair center. I think that is easier said than done ;-). I also tried DIR, with same result.
    El lunes, 21 de diciembre de 2020 09:19:48 p. m. CST, Arthur Flexser <flexser at fiu.edu> escribió:  
 While you are reseating chips, it wouldn't hurt to do so with the 6809 and
the two PIAs.  If you have another CoCo, try swapping the 6809 in from the
other one, and see if it affects the problem.  (A CoCo 3's 68B09 will work
in a CoCo 1.)  I've seen 6809 flakiness do odd things.



More information about the Coco mailing list