[Coco] NitrOS9 boot problems

Robert Gault robert.gault at att.net
Wed Dec 11 08:58:12 EST 2019


Normally you would see   i2xo   but the data you see indicates:
i - Init module found
2 - entered OS9p2 now KrnP2
x - tried to chd/chx to default device from Init module - usually /DD
t - tried but failed the above
o - tried to open default output device from Init module - usually /Term
*W - $57+$80=$D7 bad path name

As Tormod suggested your Init in OS9Boot may be incorrect or there may be other problems with your 
OS9Boot file. Given that you are trying to boot from a hard drive - SuperIDE - there may be problems 
with the file structure on the hard drive.
What you should try is to boot from a floppy or perhaps Drivewire including the modules needed to 
access your SuperIDE hard drive. You may then be able to correct any problems that might be present 
on the hard drive.


Alex Evans wrote:
> I have a previously working boot on my SuperIDE that has stopped
> working. It starts up, then shows:
> A list of modules as they are loaded. After Clock2 it shows i2xto*W
>   What error code is indicated, I know that it has previously been
> posted how to figure this out.

More information about the Coco mailing list