[Coco] ih_ide.dd not working as intended

Retro Canada retrocanada76 at gmail.com
Fri Sep 28 08:44:11 EDT 2012


I'm trying to access the SuperIDE HDB-DOS virtual drive 255 from NitrOS-9.
As I could see in the documentation, the descriptor ih_ide.dd should
be already set to access it. But it is not true. This descriptor
is mounted as I0 and access the normal  OS-9 partition on IDE master.

So I decided to checkout the NitrOS-9 from cvs and rebuild it. After
rebuilding it I could see the $(HDBDOS) flag is empty when assembling
the superdesc.asm, so this descriptor goes as a normal IDE one.

Then following the very few instructions I tried to ded it to reflect
the correct values, drive 255, DNS bit #3 set and offset = $052ddc.
According to the SuperDriver User Manual and deducing from assembly
code those values should be:
IT.STP  (offset $14) = $FF (drive number 255)
IT.DNS  (offset $16) = $08 (bit #3 set)
IT.OFS1 (offset $25) = $05
IT.OFS2 (offset $25) = $2d
IT.OFS3 (offset $25) = $dc

I also tried to change the device letter to B (offset $2b) without
sucess. The NitrOS-9 does mount it as B0 but trying to access it gives
no permission or device busy error.

What could be wrong ?

Here is the modified descriptor:

87CD 0041 002B F189 A700 2D00 30FF 07FF 5016 0100 FF81 0800 7F40 0100 2000 2001
0800 0000 0005 2DDC 0037 FF42 B052 42C6 7262 7375 7065 F26C 6C69 64E5 0000 D491

Does anybody here have a valid ih_ide.dd that does access HDB-DOS drive 255 ?
Could you send it to me ?


More information about the Coco mailing list