[Coco] NOS-9 and Basic09/RunB woes

Wayne Campbell asa.rand at gmail.com
Wed Feb 1 13:42:41 EST 2012

Boisy had suggested that the shell might be the problem. I changed which 
shell I used, making shell_21 the shell, and the same result occurred. That 
result is the program never gets launched, as the system hangs upon pressing 
the enter key (as in /DD:decode [ENTER]). Soft reset reboots NOS-9, but 
there is no other way out. BREAK and SHIFT-BREAK do nothing.

If I try running it using runb in the command (/DD:runb decode [ENTER]), I 
get a insufficient memory error (32, internal to Basic09). Using the memory 
modifier (runb #30k decode [ENTER] or runb decode #30k [ENTER]) reports a 
procedure not found error (43, also internal to basic09).

I am not running NOS-9 on a real coco3. I am using the MESS emulator. This 
is all the information I can provide, other than with stock OS-9 the same 
command (without runb or the memory modifier) also returns a 43 error. I am 
beginning to wonder if the problem isn't in MESS, though I do not understand 
how MESS could have anything to do with it.


----- Original Message ----- 
From: "Robert Gault" <robert.gault at att.net>
To: "CoCoList for Color Computer Enthusiasts" <coco at maltedmedia.com>
Sent: Wednesday, February 01, 2012 4:43 AM
Subject: Re: [Coco] NOS-9 and Basic09/RunB woes

> Wayne Campbell wrote:
>> When I had my CoCo3 and OS-9 L2, I could write a procedure that would 
>> check for a no parameter error and have my program list the built-in help 
>> in response. I have tried with both the 6809 and 6309 versions of NOS-9 
>> L2, and both systems hang when I try to run a Basic09 I-Code program from 
>> the command line with no parameters when it is expecting a parameter.
>> Also, in the stock OS-9, I could use ctrl-w to pause a listing in 
>> Basic09, but neither NOS-9 versions allow it. ctrl-w is ignored until the 
>> listing is completed.
>> I don't know if these issues are with the OS or with the NOS versions of 
>> RinB and Basic09. Has anyone else had experience with this, and is there 
>> any possibility that someone who knows assembly could/would be willing to 
>> look at the system's source and see if they can tell what's going on?
>> Wayne
> The documentation for NitrOS-9 that came with the Northern Exposure 
> package states:
> "Basic09 and RunB
> -----------------
> Without patching, the BREAK and Shift-BREAK keys become inoperative. These 
> patches modify the register stack offsets in Basic09 and RunB."
> Patched versions of Basic09 and RunB were supplied. The current versions 
> supplied with the Sourceforge NitrOS-9 work correctly with BREAK. They 
> also work correctly with the PARAM statement.
> You may need to post some code to get good answers.
> --
> Coco mailing list
> Coco at maltedmedia.com
> http://five.pairlist.net/mailman/listinfo/coco 

More information about the Coco mailing list