[Coco] Disto Super Controller & OS-9

Stephen Castello zootzoot at cfl.rr.com
Mon Mar 30 15:20:49 EDT 2009

On Mon, 30 Mar 2009 12:54:15 -0500, Roger Taylor <operator at coco3.com>
had a flock of green cheek conures squawk out:

>I'm having a devil of a time trying to boot into anything OS-9 
>related, even from original floppies.
>I just tried to boot a Deskmate boot disk, but my SC ROM socket 4 was 
>switched in and started.  I know this because I have the bitbanger 
>copy of CoCoNet in socket 4, and it started up right about the time 
>the OS-9 title screen should have appeared.  I initially got the 
>expected OS-9 BOOT message followed by track jumping for a bit, then 
>crashola.  Sometimes OS-9 doesn't get far before it crashes.  I get 
>video sparklies or random garbage, the motor relay comes on, etc. 
>(just in case somebody asks me the silly question of How is it crashing?).  :)
>Is this a known problem?  I've tried my 3.5" drive and 5.25" drive, 
>so I think it's the controller or it's addressing scheme.  I might 
>have to burn a clone of Disk BASIC to put in socket 4 if somehow the 
>sockets are being switched between by mistake or hardware 
>glitch.  Very odd this is.

For my coco 3, that usually means the 512kb memory board connections
or the cart slot connections need cleaning.

More information about the Coco mailing list