[Coco] Re: [Color Computer] Create NitrOS9 L1 boot disk for Dragon with FD-502?

Gene Heskett gene.heskett at verizon.net
Sun Sep 24 12:46:26 EDT 2006

On Sunday 24 September 2006 05:45, drag0n1969 wrote:
>I need help creating a NitrOS9 Level 1 boot disk for my unique
>configuration: Tano Dragon with a Tandy FD-502 disk controller.
>I have replaced the FD-502's EPROM with a special version of Dragon
>SuperDOS, modified by Phill Harvey Smith to work with the Tandy
>controller hardware. This works perfectly under basic.
>Creating a NitrOS9 boot disk is a problem, since the Dragon Dos
>expects the boot sector on track 0 (from sector 3), and not track 34
>as on the CoCo (though both of them load the boot sector to same
>memory address at $2600)

>From sector 3?  Since the F.A.T. starts at LSN1 on a coco/os9 disk, and can 
extend to 65535 bytes, which is several tracks, dragon either moved the 
F.A.T., or did some other VERY interesting tricks.  Please tell us more.

>Am I correct that my boot disk should simply be a Dragon NitrOS9
>boot disk with the modules BOOT and RB1773 from the CoCo (replacing
>the dragon's BOOT and DDISK)?
>I have tried using MESS to generate this bootdisk – with no success
>I also tried generating a CoCo bootdisk, replacing the VTIO and
>COVDG – to get a proper Dragon keyboard. Didn't work either

>I'm starting to think that the BOOT module contains info about both
>the physical boot sector location, and the controller hardware: thus
>if I use the Coco boot module it finds the hardware, but looks for
>the boot module in sector 34 rather than sector 0.
That would be 'track' 34 for the coco, not 'sector' 34 for starters.

>If this is a correct, I guess the Coco boot module needs to be
>patched to read sector 0?

And it would also need to be patched for the number of sectors to load 
unless the dragon boot track is shorter.  As every byte of track 34 is in 
use for the coco, I can't imagine how the dragon could get by with an 
initial load thats 768 bytes shorter.  It simply wouldn't fit.

>I have also tried to "force" the dragon to boot a CoCo bootdisk,
>using a small program on the Dragon to read sector 34 from the CoCo
>boot disk, poke it into address 9728 ($2600)  onwards, and EXEC
>9730. Doesn't seem to work either

It might, if you load track 34, all $4600 bytes of it.  Note thats assuming 
that the location of os9boot is properly coded into sector 0 so the rest 
of the bootfile can be found.  The boot module has no concept of a 
filesystem with directories at that point in the boot, so it simply reads 
LSN0 for the location and length of the os9boot file and blindly hits the 
hardware with those addresses, for that many bytes.  However, AIUI, Rel 
also sets up the memory map and relocates what was loaded from track 34 to 
the proper place in memory first, before loading the rest of os9boot via 
the above, look it up in LSN0 method.

>I have been struggling with this for quite a while now, trying
>numerous combinations. Any help would be greatly appreciated

I expect Boisy, or possibly Robert Gault can offer more help than I can, so 
I'll step aside and go back to lurking.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Yahoo.com and AOL/TW attorneys please note, additions to the above
message by Gene Heskett are:
Copyright 2006 by Maurice Eugene Heskett, all rights reserved.

Brought to you by the 6809, the 6803 and their cousins! 
Yahoo! Groups Links

<*> To visit your group on the web, go to:

<*> Your email settings:
    Individual Email | Traditional

<*> To change settings online go to:
    (Yahoo! ID required)

<*> To change settings via email:
    mailto:ColorComputer-digest at yahoogroups.com 
    mailto:ColorComputer-fullfeatured at yahoogroups.com

<*> To unsubscribe from this group, send an email to:
    ColorComputer-unsubscribe at yahoogroups.com

<*> Your use of Yahoo! Groups is subject to:

More information about the Coco mailing list