[Coco] Can't run Telewriter-64 from CoCoSDC

Darren A mechacoco at gmail.com
Sat Mar 12 17:02:23 EST 2016

On Sat, Mar 12, 2016 at 2:27 PM, Mike wrote:

> Maybe this is a known issue? I didn't get any hits when searching the mail
> list archive.
> I'm having a strange issue on my CoCo 2 with SDC. If I run Telewriter-64
> from an SDRAM image, it hangs after the "COGNITEC" splash page.  Normally,
> the disk is accessed a few times before the TW main menu appears, however,
> I don't see any LED activity on the SDC after the splash page.
> I can copy from the SDC to a real floppy disk (BACKUP command) and TW runs
> fine from a real floppy disk. I even tried copying TW-64 from an old TW-64
> disk to the SDC and I get the same results - it doesn't want to run
> directly from the SDC.
> I've tried two different SDCs (both MCU v116 / SDC-DOS 1.2) with two
> different CoCo 2s, with and without a multi-pak. Nothing seems to change
> the result. The CoCos were a 26-3127 and 26-3127B. Diagnostics on the
> CoCo2s have passed without issue.

It may be that TW-64 doesn't get along well with the patches present in
SDC-DOS.  Assuming you have standard Disk Basic 1.1 present in flash bank
1, try mounting the TW-64 disk using SDC-DOS, then entering RUN @1 to
re-boot into plain DECB before starting the program.

- Darren

More information about the Coco mailing list