[Coco] MShell and CoCo3FPGA with Analog Board

Stephen Pereira spereira1952 at comcast.net
Sun Jul 10 15:23:17 EDT 2016

Hi Bill,

I wanted to offer you an update to my MShell activities.  This weekend, I installed the Analog Interface board that I purchased from Ed (Zipster).

I have the Analog Interface attached and successfully running with Gary Becker’s latest FPGA software.  I tried out MShell and it works well.  My version was 01.00.03S.  With the Analog Interface installed, I can finally use my Tandy Color Computer Mouse (yes, the one with the two pound steel ball inside)!

When I got around to trying the update command, I saw that the current version you have is 01.00.03V, so I updated.  The update went flawlessly.  I am amazed with your update over the Internet through Drivewire process.  However, this version of the MShell is not working well for me.  It does not seem to recognize the mouse.  It thinks that I have the Hi-Res interface installed (I do not).  When I try to call up a menu, it pulls the wrong one, and it gets confused, sometimes showing two menus at once.  It did not work for me, I am sorry to say.

I went back to my pervious beta .dsk image you sent me, and I have re-installed 01.00.03S again, and all is well for me right now.  I tried the memory test and it properly shows that I have 2 MB RAM available.  I actually have 4 MB, but I believe 2 MB is the limit for NitrOS-9, right?

Anyway, I thought that I’d send you some up-to-date feedback.  Please let me know if there is some experiment that you’d like me to carry out.  I am still looking forward to all those goodies that you say are being developed for MShell!

Stephen M. Pereira
Bedford, NH  03110

More information about the Coco mailing list