[Coco] Help with Nitros9 on SDC?

Don Barber don at dgb3.net
Sun Apr 11 10:03:44 EDT 2021

Hi folks, me again. Three things I was hoping for help with:

With NOS9 3.3.0, booting from the sdc image, whenever I run the 'sdc' or 
'sdc2' utility, even without any options, I start getting error 244 
afterwards. What am I doing wrong? Its almost like nos9 is cut off from 
its own filesystem. Are these utilities written assuming nos9 is running 
from a disk source other than the sdc, such as real floppy or drivewire?

I tried to install KBCom by mounting the NOS9 sdc image in drive0, the 
kbcom disk in drive1, booting nos9, then chx /sd1/cmds and running 
'install'. However, this install script insists on writing to /d0 
instead of /sd0, which triggers the seek error described in my last 
email. Is there any workaround? In linux (if I couldn't just modify the 
script directly) I'd be looking at using a symlink, an overloaded mount 
point, or even a chroot to workaround.

Due to my frustrations with stock NOS9 and the SDC, I thought I'd try to 
use EOU to see if it played better with the SDC. So I downloaded EOU 
beta 6.0.1...and get a fail on boot. I'm using the 68SDC.VHD image. It 
loops through the modules and after ...'Clock Clock2 it*j' it stops and 
says 'FAILED'. I am running in a 512K coco3 with 6809. Thoughts?

Any help is greatly appreciated.



On 4/10/21 1:12 PM, L. Curtis Boyle wrote:
> There is also the SDC and SDC2 utilities for switching disk images on the SDC, after you are already booted (Eventually I will build this into GShell as well, to make it easier).
> L. Curtis Boyle
> curtisboyle at sasktel.net
>> On Apr 10, 2021, at 9:00 AM, Doug Fraser <zathrasldf at outlook.com> wrote:
>> Michael,
>> By using the mdir command, you'll get a list of all modules in memory. IIRC, drive 1 is '/h1' .
>> However, issue the mdir command to see the modules in memory, that is a good starting point.
>> Doug
>> Get Outlook for Android<https://aka.ms/ghei36>
>> _<snip>

More information about the Coco mailing list