[Coco] Help with Nitros9 on SDC?

Don Barber don at dgb3.net
Fri Apr 9 22:24:43 EDT 2021

Hi folks, hoping someone here can help me out. I first taught myself 
basic on a coco3 circa 1989 at 9 years old, but lost it later after I 
got out on my own and my parents moved a few times. Since then I've had 
a few decades more of experience, including a CS degree and 25+ years of 
IT and development work, and I've picked up another coco3...and its even 
more fun now that I have a clue whats going on under the covers! 
However, I'm trying to get NitrOS9 going with a new cocosdc, but I'm 
having issues, and hope someone can help point me in the right direction.

I've grabbed the latest 6809 coco3 zip (from 2014) from 

I've extracted nos96809l2v030300coco3_cocosdc.dsk, renamed to nos9.dsk 
and placed it on the sd card.

I start up sdc-dos, and enter:

drive 0,"nos9"

and nos9 boots, seemingly fine. However, before long if I try to copy 
anything new to the drive, or create any sizable files, I start getting 
error 247 (seek error) and then following that, error 244 (read error). 
The trigger can be as simple as trying to 'dcheck /d1' on another floppy 
image and says:

dcheck: cannot open workfile '/DD/dcheck030'
ERROR #247

However, when I boot to nos96809l2v030300coco3_40d_1.dsk and 
nos96809l2v030300coco3_40d_2.dsk instead of the !_cocosdc.dsk image, 
everything behaves as expected. When I boot to the !_40d_1.dsk, with the 
!_cocosdc.dsk image mounted on drive 1, I also get error 247 (seek 
error) when accessing /d1, so it seems to be a problem with accessing 
the larger disk image, but not a problem with the 360k floppy images. 
This makes me conclude one of the abstraction layers (nos9, the sdc rom, 
something) isn't handling the larger images correctly....but I'm at a 
bit of a loss on how to debug this further.

I think I covered the basic debugging: 1/ its a good fat32 filesystem; 
ran "mkfs.fat -F 32 /dev/sdb1" on a linux box myself 2/confirmed cocosdc 
is running the latest version (SDC-DOS 1.6) 3/the memory in my coco3 is 
good (used the 512K memtest from Performance Peripherals found on 
colorcomputerarchive.com and let it run for several hours) 4/Confirmed 
the same result using the nos9 nightly build images 5/Tried a different 

In case it helps, dcheck on the 4.5mb nos9 image shows this:

$0900 bytes in allocation map
1 sector per cluster
$004800 total sectors on media
Sector $00000A is start of root directory FD
$0013 sectors used for id, allocation map and root directory
Building allocation map work file...
dcheck: fatal read error
ERROR #247

Nothing on the sector math jumps out to me as being wrong, so I think 
nos9 is detecting it fine....does this point to a problem internal to my 
cocoSDC? On Linux I'd be completely at home diving into dmesg and /proc 
to figure this out, but I'm at a bit of a loss here.

Does anyone have any ideas on what I'm missing? Should I be mounting the 
larger drive images differently on the cocosdc? Is there a nos9 driver 
I'm missing for accessing larger images on the sdc?



More information about the Coco mailing list