[Coco] EmuDisk floppy utility issue

Wayne Campbell asa.rand at gmail.com
Sat Jan 4 14:56:34 EST 2020

OS-9 uses CR as a line terminator. TextPad recognizes this as the Mac
paragraph terminator. Notepad automatically changes the CR to CR+LF. That
is what is messing with the compiler in OS-9. Basic09 has a similar issue
with source files that have CR+LF line terminators. It adds an extra line
in the listing between source statements. TextPad allows Mac-style line
terminators, and this corrects the issue.

I was referring to transferring text files from floppy images to a Windows
folder. EmuDisk is doing something strange to the file descriptor. The file
contents are fine, but TextPad is getting some weird character from the
file descriptor that is causing it to crash. Notepad apparently ignores the
file descriptor.


On Sat, Jan 4, 2020, 11:17 AM Walter Zambotti <zambotti at iinet.net.au> wrote:

> Hi all
> What I found with transfering text files between Windows/Linux to OS9 is
> you have to be very careful with line termination characters.  The file can
> look good to some utilities on the receiving end but cause problems with
> others.  Using notepad on a source file will stop the os9 compiler from
> working.  I find resaving the file with minted helps.
> Walter
> Sent from my Xperia by Sony smartphone
> ---- Bill Pierce via Coco wrote ----
> >Actually, there's quite a few issues with that software. I wouldn't move
> anything around in OS-9 with it, without a backup.
> >He had a good plan and good concept, he just never worked the kinks out
> of it.
> >
> >
> >
> >-----Original Message-----
> >From: Wayne Campbell <asa.rand at gmail.com>
> >To: CoCoList for Color Computer Enthusiasts <coco at maltedmedia.com>
> >Sent: Wed, Jan 1, 2020 8:06 pm
> >Subject: [Coco] EmuDisk floppy utility issue
> >
> >It's been a few years since this utility was written. I don't know if Walt
> >Zydhek is still around, but if he is I have found an issue with EmuDisk
> >that needs to be addressed. I used the utility to copy a text file from a
> >floppy image to a windows folder. When I tried to open it with TextPad
> (the
> >editor of choice for me), TextPad reported "Unspecified Error", and when I
> >clicked the OK button I got another dialog stating, "Unexpected and
> >unrecoverable error. Would you like to save a diagnostic file?" TextPad
> >then quit after clicking either of the buttons (Yes or No). I opened the
> >file with Notepad and it opened fine.
> >
> >If I save the file out with wimgtool, the file opens without error in
> >TextPad. I don't understand what is causing the issue, but it appears to
> be
> >related to how EmuDisk is saving the file. I also compared the two copies
> >(one from wimgtool and one from EmuDisk) in the file comparison utility
> >WinMerge and it showed both files being identical. This just adds to my
> >confusion, as one opens in TextPad and Notepad and the other only opens in
> >Notepad.
> >
> >I would appreciate any help in figuring out what is happening here, but I
> >haven't heard from Walt in a long time. In the meantime I am just using
> >wimgtool to copy files from floppy images to my windows folders.
> >
> >Wayne
> >
> >The Structure of I-Code
> >http://www.cocopedia.com/wiki/index.php/The_Structure_of_I-Code
> >
> >--
> >Coco mailing list
> >Coco at maltedmedia.com
> >https://pairlist5.pair.net/mailman/listinfo/coco
> >
> >--
> >Coco mailing list
> >Coco at maltedmedia.com
> >https://pairlist5.pair.net/mailman/listinfo/coco
> --
> Coco mailing list
> Coco at maltedmedia.com
> https://pairlist5.pair.net/mailman/listinfo/coco

More information about the Coco mailing list