[Coco] VCC 2.0.2 with full 6309 emulation. Runs Nitros9 EOU 6309.

Walter Zambotti zambotti at iinet.net.au
Sun Dec 8 22:06:48 EST 2019


I probably made some changes because I found MemRead/Write32 in tcc1014mmu.c

Anyway I tried to use the VS2015 to make an installable package and it does work a little better but for some reason is still not auto detecting all dependencies.

This gives me the problem where it runs but any menuing option that requires a file browser does not open the browser! And I'm forced to configure VCC via the ini file.

So I am going to make a clean VCC2.01 project and start from scratch!!!

This might take me some time so meanwhile I have returned the MemWrite/Read32 functions back into hd6309.c , tested it on my system and uploaded the source to the google drive. As this might be the quickest approach, please try again.


-----Original Message-----
From: Coco [mailto:coco-bounces at maltedmedia.com] On Behalf Of Christopher R. Hawks
Sent: Monday, 9 December 2019 6:18 AM
To: coco at maltedmedia.com
Subject: Re: [Coco] VCC 2.0.2 with full 6309 emulation. Runs Nitros9 EOU 6309.

On Sun, 8 Dec 2019 20:06:11 +0000 (UTC)
Bill Pierce via Coco <coco at maltedmedia.com> wrote:

> Christopher, that is the link to his OVCC repo. That is his Linux 
> conversion of VCC, which is a MAJOR overhaul and not his 2.0.1b 
> conversion. The two don't even closely resemble each other. There aren 
> other branches, so I assume his "202" version of "2.0.1b" for Windows 
> is stored locally.
> -----Original Message-----
> From: Christopher R. Hawks <chawks at dls.net>
> To: coco <coco at maltedmedia.com>
> Sent: Sun, Dec 8, 2019 11:11 am
> Subject: Re: [Coco] VCC 2.0.2 with full 6309 emulation. Runs Nitros9 
> EOU 6309.
> On Sun, 8 Dec 2019 13:23:07 +0000 (UTC) Bill Pierce via Coco 
> <coco at maltedmedia.com> wrote:
> > Walter, that is not the case. I have VS2015 installed, and I still 
> > get no dialogs on disk, vhd, cass, & external rom loads.
> > 
> > Also, I just tried dropping your h6309.c & h6309.h into my 2.0.1b 
> > sln. 7 errors & 4 warnings.
> > Errors & warnings are all the same,
> > Error: "MemWrite32":identifier not found.
> > Warning: "=":conversion from 'short' to 'unsigned char', possible 
> > loss of data
> > 
> > You have definately changed something somewhere else to get this 
> > result. I did notice you commented out MemWrite32 in h6309.c, and I 
> > know that's used throughout VCC. Without knowing what's been done 
> > elsewhere, it can't be fixed.
> > 
> > You stated if having problems, build it on my system... How? the 
> > only source you provided was h6309.c. It WILL NOT work with 1.0.2b 
> > sources. I have 1.0.2b and it builds with no errors. Your changes 
> > are to vast to just drop h6309.c into it.
> https://github.com/WallyZambotti/OVCC
> [snip]
> Christopher R. Hawks
> HAWKSoft


    Thanks for the clarification. I did't realize he was running 2 different projects.

Christopher R. Hawks
Truth never hurts the teller.		 	-- Robert Browning
       \   ^__^                         
        \  (oo)\_______                 
           (__)\       )\/\           
               ||----w |                
               ||     ||                

Coco mailing list
Coco at maltedmedia.com

More information about the Coco mailing list