[Coco] Megaread problems

Dave Philipsen dave at davebiz.com
Mon Mar 27 13:44:50 EDT 2017

I guess the problem has to do with the fact that the reference to '/DD' 
is just a reference to the root directory.  If you use '/DD@' then you 
will be referencing the raw device.  Alternatively, you could create a 
file that is at least as large as the desired megaread and us it like 
this:  'megaread </dd/bigfile'.

The error #214 is normal for trying to open/read a directory.  For 
instance, try 'copy /dd mydir'.  You'll get the same error.  You could, 
however, 'copy /DD@ mydir' in which case you'd need to make sure that 
the device which will hold 'mydir' is larger than the 'DD' device itself.


On 3/27/2017 7:35 AM, Robert Gault wrote:
> Something very strange is going on with the version of megaread in the 
> current NitrOS-9 builds. The program works correctly for Dave 
> Philipsen and possibly everyone else. It fails for me on any system I 
> try.
> megaread 1 </DD
> The above should run the program for the minimum number of reads with 
> standard input changed to /DD. For MESS, VCC, and a 512K Coco3 the 
> result is error #214.
> megaread </DD
> Same error as above for the default 1024 repeats.
> The crc for the version under test is $A5A49C, size $7A which is 
> identical with the nightly build version. Attr for tested drives 
> indicates normal values.
> Robert

More information about the Coco mailing list