[Coco] Imaging MM/1 Floppy Disks

Joel Ewy jcewy at swbell.net
Thu Dec 31 17:58:27 EST 2015

I'm trying to image some MM/1 floppy disks, and not having any success 
yet.  The Toolshed documentation suggests using setfdprm from the 
fdutils package to configure /dev/fdX for a CoCo floppy disk.  In the 
example, it uses a preset definition:  coco40ds which I can't find 
anymore.  In any case, the MM/1 format is different. However, using the 
documentation here: http://www.fdutils.linux.lu/Fdutils.html#SEC22 I 
came up with a plausible setfdprm command:

sudo setfdprm sect=33 hd ssize=256 cyl=80.

The syntax seems to be accepted.  This page: 
http://www.fdutils.linux.lu/disk-id.html suggests that one should then 
be able to use

cat /dev/fd0 >image.dsk

to write the image file.  When I try this, it fails with an Input/Output 
error, writing 0 bytes to the file.  I also tried

dd if=/dev/fd0 of=image.dsk bs=256

and got the same results.  I tried two different disks and got the same 
results.  The first one I tried is a freshly formatted, previously 
unused disk that I backed up a boot floppy onto on the MM/1 with no 
error reported on the backup.  When I did the backup, it first 
complained that the formats weren't identical.  A vague recollection 
returned that the boot disks were formatted to 33 sectors, while the 
device descriptors for /d0 and /d1 are set for 37 sectors.  Presumably 
the boot ROM expects 33 sector disks.  There is a floppy disk format 
table in the MM/1 Technical Manual that describes the MM/1 format as 33 
sectors.  So I used dmode to change the sct and t0s to 33, and 
reformatted the floppy.  Then backup was happy to copy the disk.

The drive I'm using to try to make the image can read a FAT formatted 
floppy that I can also read on the MM/1, so I'm pretty confident it 
isn't a hardware issue.

Any ideas what I'm doing wrong?


More information about the Coco mailing list