[Coco] Bug in VCC ???

Bill Pierce ooogalapasooo at aol.com
Wed Apr 16 12:42:57 EDT 2014

Luis, I tried it i VCC 1.4.3beta and I get the CPM logo, then it seems to scroll one line at a time but no text displays for at least a screen of lines, then ending in a:
--------------------- More --------------------
prompt. Hitting any key makes it scroll more, same results.

I tried it again in VCC 1.4.3beta+FSTEST1 (Aaron's latest patch) and it did the same thing. The same also happens in Vcc 1.4.2

Bill Pierce
"Today is a good day... I woke up" - Ritchie Havens

My Music from the Tandy/Radio Shack Color Computer 2 & 3
Co-Webmaster of The TRS-80 Color Computer Archive
Co-Contributor, Co-Editor for CocoPedia
E-Mail: ooogalapasooo at aol.com

-----Original Message-----
From: Luis Antoniosi (CoCoDemus) <retrocanada76 at gmail.com>
To: CoCoList for Color Computer Enthusiasts <coco at maltedmedia.com>
Sent: Wed, Apr 16, 2014 12:16 pm
Subject: [Coco] Bug in VCC ???

I noticed the VCC 1.43beta won't run my cpm emulator running zork1.com properly.

It seem to get a wrong conditional jump and goes crazy scrolling the screen up.

The same image DOES work on MESS and a real Coco3. The Mbasic.com
seemed at beginning to work fine.

I'm using a direct lookup table to convert 6809 flags to Z-80 flags.
So it could be the case some instruction setting or resetting a wrong

I have no clue which instruction is that since I don't use VCC (it
does not have a debugger it has no purpose for me).

The cpm disks:


Mount zork.os9 (80T disk image) and run

/d1/cpm zork1.com

And you will see the bug right away.

Long live the CoCo

Coco mailing list
Coco at maltedmedia.com


More information about the Coco mailing list