[Coco] Nitros9 Boot Disk "issues"

Roger Merchberger zmerch-coco at 30below.com
Mon May 22 01:20:19 EDT 2006

Well, the "issues" I have is that I are stoopid...

I snagged the latest version of Nitros9, and I want to make "real" boot 
disks for my CoCo3 setup to eventually transfer to Compact Flash on the 
SuperIDE interface... but I have a few limitations, and this is giving me fits.

My PC system won't format a readable DS floppy with OmniFlop, but I can 
write disks if they're formatted first on the CoCo; but as I don't have a 
working Nitros9 boot floppy yet, I can't format a DS disk on the CoCo. So, 
I'm limited to DECB for formatting which limits me to single-sided disks.

Yes, I *do* have Drivewire, yes I can boot nitros9 3.2.4 on it, no I 
*can't* format real floppies on the system... When XP doesn't bluescreen 
due to buggy Belkin USB->RS232 drivers (which I believe I've got the right 
drivers now, but I've not tested it yet) the CoCo locks *hard* no later 
than halfway through the format. :-( I've tried it *at least* 50 times with 
the same result (yea, I'm a glutton for punishment) so there's got to be 
some weird little timing issue or something with nitros9 3.2.4 and/or 
drivewire and/or my hardware and/or the alignment of the planets...

I've taken the stock standard.bl file and made DS boot disks no problem, 
but SS is just no worky.

I've tried creating new SS device drivers - is it safe to assume that 
dmode'ing the /dd and /d0 drivers, save'ing them to a different disk, 
copying them into the ../MODULES/RBF directory and calling them from the 
standard.bl bootlist is all that's necessary to get a working device 
driver, or am I missing something? (At first, I thought I was missing 
something, until I tried making a boot disk with the supplied 35tk SS 
drivers, and that won't boot, either.)

It shows:

KREL Boot Krn tb0.......

(Yes, that's 7 dots after tb0) and locks.

Now, *waaaaayy* back in the day, I could diagnose a failed OS-9 boot just 
by the sound of the floppy drive, but I've been testing builds in the 
emulator - faster turnaround. MESS .103, CoCo3 6809 ROM.

Any hints/tips/quibbles/quarrels/brickbats available out there?

Good thing:

My knowledge of OS-9 has improved immensely over the last few hours!

Bad thing:

My knowledge of 'edit' has improved immensely over the last few hours!

Is there a small freeware full-screen editor for Nitros9 out there 
anywhere??? I'm spoiled by Jove on the Linux platform... rather like 
nano/pico but with a more emacs-like key-command set, so moving to/from 
emacs is effortless... However, I'd be more than happy to learn a new 
keyset... I'm OK with vi as well, but AFAIK TS-Edit was never ported to the 
80-column screen, was it?

Anyway, thanks any & all for help on trying to get this rascal over to the 
"real thing."

Thanks & Have a good nite!
Roger "Merch" Merchberger

P.S. I have moved over the DriveWire RBF drivers to the Nitros9 boot disk 
on the emulator - would attempting to make a DriveWire boot disk be as 
simple as using the DW /dd and /d0 drivers to make a new boot disk? Would I 
be better served trying this next? Or is the bootdisk crashing before that 

Roger "Merch" Merchberger  --  SysAdmin, Iceberg Computers
zmerch at 30below.com

Hi! I am a .signature virus.  Copy me into your .signature to join in!

More information about the Coco mailing list