[Coco] Re: [Color Computer] Rom PAK to tape?

chazbeenhad chazbeenhad at hotmail.com
Fri Apr 30 18:55:31 EDT 2004

--- In ColorComputer at yahoogroups.com, "chazbeenhad" 
<chazbeenhad at h...> wrote:
> --- In ColorComputer at yahoogroups.com, "Neil Morrison" 
> <neilsmorr at h...> wrote:
> > 
> > ----- Original Message ----- 
> > From: "chazbeenhad" <chazbeenhad at h...>
> > 
> > 
> > > Can someone explain to me how to save a ROM PAK to tape?
> > >
> > > Thank you!
> > >
> > > -Charlie
> > 
> > You have to tape over the right hand connector on the pak, 
> it, power
> > up, and dump it.
> > 
> > CSAVEM"XXX",&HC000,&HFE00,&HC000
> > 
> > or similar is the command. Many variations may be required.
> > 
> > Neil
> Thanks. I guess I need more help. So let me explain everything.
> I'm trying to use the DAGGOPATCH to play Dungeons of Daggorath on 
> disk system.
> I found this nice web site on how to save my DoD rom pak to tape.
> http://home.att.net/~robert.gault/Coco/Unpublished/CART2RAM.html
> I did what it says, but when I run TAPEGEN I always get an IO 
> in 150.
> When I try to use MPAKGEN with my multipak interface in my COCO3 I 
> get a wierd result. I put my Disto SCII in slot 4 and the DoD rom 
> pak in slot 1. When I run MPAKGEN it searches for the pak and then 
> the Ext Disk Basic 1.1 logo appears on screen and nothing happens.
> Thats wierd cause when I 1st boot the COCO3 it says Ext disk basic 
> 2.1.
> So I either need someone to send me a "dumped" DISKDAG file, or to 
> tell me what I can do to make this work.
> Also, I do have DoD dumped to a disk .BIN file. I did that a long 
> time ago. I don't know if there is a way to use that file to help 
> Thanks.
> Charlie

Alright! I got it working perfectly. There was 2 things that were 
wrong with my bad attempts.

1, When trying to Daggopatch from my multipak, I was getting an IO 
error in 130. I didnt realise I used a 1.2 disk in my PC to make the 
daggopatch floppy for the coco. Line 130 was trying to LOADM 
something and it was bad on the disk. Thus the error. SO I went back 
to the PC and remade the disk with a 360K and all was good. That 
happens sometimes when using 1.2 disks with dskini on the PC. 
SOmetimes the image writes good, other times you get bad files.

2, I also didn't know you had to keep the tape on the rom pak when 
it was in slot 1 of the multipak. I assumed the tape was only for 
trying to do a tape save of the rom pak......opps.

Now I can play DoD with out hooking up the tape drive :-)


------------------------ Yahoo! Groups Sponsor ---------------------~-->
Buy Ink Cartridges or Refill Kits for your HP, Epson, Canon or Lexmark
Printer at MyInks.com.  Free s/h on orders $50 or more to the US & Canada.

Brought to you by the 6809, the 6803 and their cousins! 
Yahoo! Groups Links

<*> To visit your group on the web, go to:

<*> To unsubscribe from this group, send an email to:
     ColorComputer-unsubscribe at yahoogroups.com

<*> Your use of Yahoo! Groups is subject to:

More information about the Coco mailing list