[Coco] MShell and CoCo3FPGA with Analog Board

Bill Pierce ooogalapasooo at aol.com
Sun Jul 10 19:42:35 EDT 2016

Stephen, when you get a chance, try the updater again and see if it works properly now as well. There's a chance that something between the updater, the CocoFPGA, and the version of NitrOS9 being used, is mangling that file. I was having problems with this in Vcc and the Coco at one time, but solved it. If that's the case for the CocoFPGA, then I think I know how to resolve that as well. It's all in the timing. I run VCC at 89mhz while programming, so since MShell is actuall 2 modules running at once, I occassionally found I needed to make some routines "sleep" for a fraction of a second to let the other module catch up. I was having this very problem with the updater as it was deleting something before it was finished copying, so I had to add a sleep cmd to give it a second to finish.
Since the CocoFPGA runs at 25mhz, it may make the timing slightly different and I may need to adjust the sleep cmd.



Bill Pierce
"Charlie stole the handle, and the train it won't stop going, no way to slow down!" - Ian Anderson - Jethro Tull


My Music from the Tandy/Radio Shack Color Computer 2 & 3
Co-Contributor, Co-Editor for CocoPedia
Global Moderator for TRS-80/Tandy Color Computer Forums

E-Mail: ooogalapasooo at aol.com



-----Original Message-----
From: Stephen Pereira <spereira1952 at comcast.net>
To: CoCoList for Color Computer Enthusiasts <coco at maltedmedia.com>
Sent: Sun, Jul 10, 2016 7:27 pm
Subject: Re: [Coco] MShell and CoCo3FPGA with Analog Board

Hi Bill,Yes, that did the trick!  I used the .dsk image you pointed me to, and I was able to update to version 1.0.3V, and it works just fine.Thanks very much!  I am very glad to be up and running on the latest update, and I look forward to any future updates that you may have.  As always, please let me know if you have any experiments that you would like me to run.  So far, with all of your effort, MShell is running fine on the CoCo3FPGA, latest version, and with the new Analog Interface board.  I’m using the mouse!  Yay!smp--Stephen M. PereiraBedford, NH  03110KB1SXE> On Jul 10, 2016, at 6:32 PM, Bill Pierce via Coco <coco at maltedmedia.com> wrote:> > Stephen, I think I see the problem. I think I forgot to upload the updated menu file "ms1a.men" (or it is corrupted). Give me a few minutes and I should have it uploaded. If this doesn't fix it, then something is not not right in the CocoFPGA version of NitrOS9 as this all works perfectly in Vcc running NitrOS9 v3.3.0 and did work fine on my real Coco before I took it down.> There may be a slight chance that the MSHell, the CocoFPGA and DW4 are having a slight timing problem and mangling the last file updated (Ms1A.men). This would cause what you are seeing as well as it sounds like everything is working, just menus not showing correctly, therefore not selecting correctly. This all ties back to the ms1.men file which holds all the menus, their loacations and relations.> > The only other thing I can think of is that the CocoFPGA is not reading the mouse coordinates correctly. Seeing as how older versions of MShell have worked for you, I don't think this is the case.> > To see if the updater is mangling the file, try using the disk image from the MShell site, using the "install". I just updated it as well> > https://dl.dropboxusercontent.com/u/23059963/MShell/MShell%201.0.3v.zip> > As usual, let me know the results. I really appreciate the testing. I have fixed many things this way :-)> > > > > Bill Pierce> "Charlie stole the handle, and the train it won't stop going, no way to slow down!" - Ian Anderson - Jethro Tull> > > > My Music from the Tandy/Radio Shack Color Computer 2 & 3> https://sites.google.com/site/dabarnstudio/> Co-Contributor, Co-Editor for CocoPedia> http://www.cocopedia.com/wiki/index.php/Main_Page> Global Moderator for TRS-80/Tandy Color Computer Forums> http://www.tandycoco.com/forum/> > E-Mail: ooogalapasooo at aol.com> -- Coco mailing listCoco at maltedmedia.comhttps://pairlist5.pair.net/mailman/listinfo/coco

More information about the Coco mailing list