[Coco] MShell and CoCo3FPGA with Analog Board

Bill Pierce ooogalapasooo at aol.com
Sun Jul 10 18:32:07 EDT 2016

Stephen, I think I see the problem. I think I forgot to upload the updated menu file "ms1a.men" (or it is corrupted). Give me a few minutes and I should have it uploaded. If this doesn't fix it, then something is not not right in the CocoFPGA version of NitrOS9 as this all works perfectly in Vcc running NitrOS9 v3.3.0 and did work fine on my real Coco before I took it down.
There may be a slight chance that the MSHell, the CocoFPGA and DW4 are having a slight timing problem and mangling the last file updated (Ms1A.men). This would cause what you are seeing as well as it sounds like everything is working, just menus not showing correctly, therefore not selecting correctly. This all ties back to the ms1.men file which holds all the menus, their loacations and relations.

The only other thing I can think of is that the CocoFPGA is not reading the mouse coordinates correctly. Seeing as how older versions of MShell have worked for you, I don't think this is the case.

To see if the updater is mangling the file, try using the disk image from the MShell site, using the "install". I just updated it as well


As usual, let me know the results. I really appreciate the testing. I have fixed many things this way :-)



Bill Pierce
"Charlie stole the handle, and the train it won't stop going, no way to slow down!" - Ian Anderson - Jethro Tull


My Music from the Tandy/Radio Shack Color Computer 2 & 3
Co-Contributor, Co-Editor for CocoPedia
Global Moderator for TRS-80/Tandy Color Computer Forums

E-Mail: ooogalapasooo at aol.com



-----Original Message-----
From: Stephen Pereira <spereira1952 at comcast.net>
To: CoCoList for Color Computer Enthusiasts <coco at maltedmedia.com>
Sent: Sun, Jul 10, 2016 5:35 pm
Subject: Re: [Coco] MShell and CoCo3FPGA with Analog Board

Hi again, Bill,Thanks very much for your quick response.  Deleting the previous init file did bring up the Config Editor, as you said.  Doing the configuration fresh made MShell work more calmly, but the menus do not work correctly.When I click on UTILS, I get the MODULE menu.When I click on any of the Module selections, the whole menu disappears.  If I type the capital letter to select, I get a click but the menu remains.When I click on MODULE, I get the TOOLS menu.When I click on SEARCH, I *do* get the SEARCH menu.When I click on TOOLS, I get the FREE DISP OPTS menu.When I click on OPTIONS, I get the COLORS menu.When I click on DRIVE, I get the FILE OPTIONS menu, with “100” as a superscript to the left of the title word “FILE”.When I click on FILE, I get the SYSTEM OPTIONS, with all options checked as active.I’ve re-installed version 01.00.03S again, and I confirm that all works well with that version.  I can pull down the MODULES menu, and if I try each of them with a click, I get a dialog box saying this feature is coming later.  If I try to select with the capital letter, I get the same dialog box for all but one of them in the middle of the list.  For that one, I get only a click.I hope this helps you.  Please let me know if there is anytjhing else I can try to assist you.smp--Stephen M. PereiraBedford, NH  03110KB1SXE> On Jul 10, 2016, at 4:31 PM, Bill Pierce via Coco <coco at maltedmedia.com> wrote:> > Stephen, Glad to know MShell is working with the CocoFPGA and Analog board. I have been following that thread (I'm also on the CocoFPGA list) and have been interested as to whether or not the mouse would work correctly with NitrOS9.> > Since MShell 1.0.3s is working fine, then 1.0.3v should as well (only minor cosmetic changes I think). The only problem I see could be that the "init" file may have changed. If the "order" of items in the init file has changed, the previous init file can stop MShell from functioning properly. The "Install" program on the distro disks solves this by deleting any old files before installing the new ones, the updater does not do this, so your old init file is probably being used and "I think" I changed the order of items in one of the last couple of updates. I need to add a cmd to delete the init file in the updater so this will not happen. > > Try this....> Use the updater to update MShell (again). After the updater finishes, exit MShell (newer versions should "auto-exit"). Now type:> > del /dd/cmds/ms1.init> > Now run the updated MShell. You should be greeted this time with a Config editor. Answer the prompts. Mshell should work correctly then. If not, let me know and we'll see if we can find the problem.> I just "updated" my working copy of MShell with the updater and it is working correctly in VCC. My Coco 3 is packed up for now so I cannot test it on the Coco, though I hope to set it back up real soon.> > > I hope this solves your problem. I will correct the init file problem in the updater (I've been meaning to do that but forgot).> > > > > Bill Pierce> "Charlie stole the handle, and the train it won't stop going, no way to slow down!" - Ian Anderson - Jethro Tull> > > > My Music from the Tandy/Radio Shack Color Computer 2 & 3> https://sites.google.com/site/dabarnstudio/> Co-Contributor, Co-Editor for CocoPedia> http://www.cocopedia.com/wiki/index.php/Main_Page> Global Moderator for TRS-80/Tandy Color Computer Forums> http://www.tandycoco.com/forum/> > E-Mail: ooogalapasooo at aol.com> > > > > > > -----Original Message-----> From: Stephen Pereira <spereira1952 at comcast.net>> To: CoCoList for Color Computer Enthusiasts <coco at maltedmedia.com>> Sent: Sun, Jul 10, 2016 3:23 pm> Subject: [Coco] MShell and CoCo3FPGA with Analog Board> > Hi Bill,I wanted to offer you an update to my MShell activities.  This weekend, I installed the Analog Interface board that I purchased from Ed (Zipster).I have the Analog Interface attached and successfully running with Gary Becker’s latest FPGA software.  I tried out MShell and it works well.  My version was 01.00.03S.  With the Analog Interface installed, I can finally use my Tandy Color Computer Mouse (yes, the one with the two pound steel ball inside)!When I got around to trying the update command, I saw that the current version you have is 01.00.03V, so I updated.  The update went flawlessly.  I am amazed with your update over the Internet through Drivewire process.  However, this version of the MShell is not working well for me.  It does not seem to recognize the mouse.  It thinks that I have the Hi-Res interface installed (I do not).  When I try to call up a menu, it pulls the wrong one, and it gets confused, sometimes showing two menus at once.  It did not work for me, I am sorry to say.I went back to my pervious beta .dsk image you sent me, and I have re-installed 01.00.03S again, and all is well for me right now.  I tried the memory test and it properly shows that I have 2 MB RAM available.  I actually have 4 MB, but I believe 2 MB is the limit for NitrOS-9, right?Anyway, I thought that I’d send you some up-to-date feedback.  Please let me know if there is some experiment that you’d like me to carry out.  I am still looking forward to all those goodies that you say are being developed for MShell!smp--Stephen M. PereiraBedford, NH  03110KB1SXE-- Coco mailing listCoco at maltedmedia.comhttps://pairlist5.pair.net/mailman/listinfo/coco> > -- > Coco mailing list> Coco at maltedmedia.com> https://pairlist5.pair.net/mailman/listinfo/coco-- Coco mailing listCoco at maltedmedia.comhttps://pairlist5.pair.net/mailman/listinfo/coco

More information about the Coco mailing list