[Coco] format memory (was) Gotek floppy emulator

Bill Pierce ooogalapasooo at aol.com
Mon Feb 15 16:57:06 EST 2016

I use 3.3.0 extensively with a large bootfile on Vcc with /d0-/d3, /h0 (emudsk), /x0-/x8 (yes 8), and /r0 (96k), with CoWin AND CoVDG and full DW4 vport/vprint/vterm support as well as pipes. My Coco 3 is the same but with EmuDsk being replaced by RBSuper IDE drivers. I can format drives with no problem (Coco 3 or VCC), even when I'm running other programs in other windows, but if I run the scripts in the "nitros9/6x09L2/scripts", format will fail. I actually had to make a stripped down boot without all my "extras" to get the scripts to run. I think that problem is the scripts load too much in memory at one time and even most "normal" bootfiles will not have enough system ram. It has nothing to do with "total machine ram" as I run VCC in 6309 with 2 meg, and my Coco3 has 6809 and 1 meg, it's the system ram (64k) that holds the entire system AND a copy of each program (or script) loaded. So the real problem is in the size of the bootfile.


Bill Pierce
"Charlie stole the handle, and the train it won't stop going, no way to slow down!" - Ian Anderson - Jethro Tull


My Music from the Tandy/Radio Shack Color Computer 2 & 3
Co-Contributor, Co-Editor for CocoPedia
Global Moderator for TRS-80/Tandy Color Computer Forums

E-Mail: ooogalapasooo at aol.com



-----Original Message-----
From: Tormod Volden <lists.tormod at gmail.com>
To: CoCoList for Color Computer Enthusiasts <coco at maltedmedia.com>
Sent: Mon, Feb 15, 2016 3:52 pm
Subject: Re: [Coco] Gotek floppy emulator

On Mon, Feb 15, 2016 at 2:19 AM, Steven Hirsch wrote:> On Sun, 14 Feb 2016, Gene Heskett wrote:>>> The bare DD drive, attached to the coco with a cable adapter CAN do this,>> IF you can make the format command work. But format even in the>> nitros9-v3.3.0 release, has been a 100% crash and burn for me for several>> years.  So my mb scripts have been re-written to clean up an already>> formatted DD disk before os9gen is invoked.  This includes making a>> directory entry for track 34, and deleting it to clear the FAT, thereby>> allowing os9gen to rewrite track 34, otherwise it silently fails to do so.>>> That's really odd behavior.  I'm running version 3.2,9 and format works> fine.Does anyone else than Gene have trouble with the format command? Canthis be reproduced in VCC?Tormod-- Coco mailing listCoco at maltedmedia.comhttps://pairlist5.pair.net/mailman/listinfo/coco

More information about the Coco mailing list