[Coco] The Hobbit ported to 6809 (Dragon64 and coCo2 64k)

Pere psergm at gmail.com
Wed Aug 31 09:44:11 EDT 2016

Hi Aaron,
right, it didn't make sense.
I was sure it was a problem created by my DOS patcher to enable
the process of 40 tracks disks.
I am sure that the HDB-DOS I used to test DW4 is not exactly the
same v1.1 as expected by the patcher.

I found that with Drivewire, I could load files, but it failed saving using:
- SAVEM"1:SAVGAM01.BIN" giving an ?FN error
I tested manually SAVEM"SAVGAM01.BIN:1" and worked nicely, so I have
changed the program to use this CoCo syntax instead of the former one.

I succeeded schrinking some four images and now all of them fit into
a standard 35 tracks disk ;-)
I have changed the code to supress the patcher routine and added a bit
of conditional compiling (for speed) and now I run the compiler and get:
- H1X.BIN that runs at normal speed
- H2X.BIN that runs double speed all the time
- HIMG.BIN that runs at double speed ONLY to load locations images

I have tested the normal speed on Dragon64, CoCo2 and CoCo2 with DW4
On CoCo3 I have tested the three executables on VCC
All these tests have worked fine.

Today I am going to make some more tests on real hardware:
- D64 with drives or with CoCo-SDC
- CoCo3 with drives or with CoCo-SDC (probably with the uDW server
  by Tormod Volden too)

As soon as the tests have been completed and no errors detected, I will
upload this drivewire compatible version.


-----Mensaje original----- 
Message: 4
Date: Tue, 30 Aug 2016 10:01:02 +0000
From: Aaron Wolfe <aawolfe at gmail.com>
To: CoCoList for Color Computer Enthusiasts <coco at maltedmedia.com>
Subject: Re: [Coco] The Hobbit ported to 6809 (Dragon64 and coCo2 64k)
<CAA6uQZQAjjdAo50RvMo8p3kkrysG-yGsZybkgbO9fbogW_umMA at mail.gmail.com>
Content-Type: text/plain; charset=UTF-8

Once again, I would be surprised if the contents of the file are causing
that error.

More information about the Coco mailing list